blob: b99ed83f6f68170aec47a7fce512520498c061f0 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f4001d1ca15b69d096fa1b4fd1bdce79"
6
Patrick Williamsde0582f2022-04-08 10:23:27 -05007SRC_URI[sha256sum] = "623bac2d6bdca3f3e61cf1e1c466c5fb9f5cf08735736ee1111187b7a4108891"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
9PYPI_PACKAGE = "SQLAlchemy"
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-json \
14 ${PYTHON_PN}-pickle \
15 ${PYTHON_PN}-logging \
16 ${PYTHON_PN}-netclient \
17 ${PYTHON_PN}-numbers \
18 ${PYTHON_PN}-threading \
19 ${PYTHON_PN}-compression \
20 ${PYTHON_PN}-profile \
21"
22
23BBCLASSEXTEND = "native nativesdk"