Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU Transport Layer Security Library" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/gnutls/" |
| 3 | BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls" |
| 4 | |
| 5 | LICENSE = "GPLv3+ & LGPLv2.1+" |
| 6 | LICENSE_${PN} = "LGPLv2.1+" |
| 7 | LICENSE_${PN}-xx = "LGPLv2.1+" |
| 8 | LICENSE_${PN}-bin = "GPLv3+" |
| 9 | LICENSE_${PN}-openssl = "GPLv3+" |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=71391c8e0c1cfe68077e7fce3b586283 \ |
| 12 | file://doc/COPYING;md5=c678957b0c8e964aa6c70fd77641a71e \ |
| 13 | file://doc/COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343" |
| 14 | |
| 15 | DEPENDS = "nettle gmp virtual/libiconv libunistring" |
| 16 | DEPENDS_append_libc-musl = " argp-standalone" |
| 17 | |
| 18 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
| 19 | |
| 20 | SRC_URI = "https://www.gnupg.org/ftp/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar.xz \ |
| 21 | file://arm_eabi.patch \ |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 22 | file://0001-Modied-the-license-to-GPLv2.1-to-keep-with-LICENSE-f.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | " |
| 24 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 25 | SRC_URI[sha256sum] = "5630751adec7025b8ef955af4d141d00d252a985769f51b4059e5affa3d39d63" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | |
| 27 | inherit autotools texinfo pkgconfig gettext lib_package gtk-doc |
| 28 | |
| 29 | PACKAGECONFIG ??= "libidn" |
| 30 | |
| 31 | # You must also have CONFIG_SECCOMP enabled in the kernel for |
| 32 | # seccomp to work. |
| 33 | PACKAGECONFIG[seccomp] = "ac_cv_libseccomp=yes,ac_cv_libseccomp=no,libseccomp" |
| 34 | PACKAGECONFIG[libidn] = "--with-idn,--without-idn,libidn2" |
| 35 | PACKAGECONFIG[libtasn1] = "--with-included-libtasn1=no,--with-included-libtasn1,libtasn1" |
| 36 | PACKAGECONFIG[p11-kit] = "--with-p11-kit,--without-p11-kit,p11-kit" |
| 37 | PACKAGECONFIG[tpm] = "--with-tpm,--without-tpm,trousers" |
| 38 | |
| 39 | EXTRA_OECONF = " \ |
| 40 | --enable-doc \ |
| 41 | --disable-libdane \ |
| 42 | --disable-guile \ |
| 43 | --disable-rpath \ |
| 44 | --enable-local-libopts \ |
| 45 | --enable-openssl-compatibility \ |
| 46 | --with-libpthread-prefix=${STAGING_DIR_HOST}${prefix} \ |
| 47 | --with-default-trust-store-file=${sysconfdir}/ssl/certs/ca-certificates.crt \ |
| 48 | " |
| 49 | |
| 50 | # Otherwise the tools try and use HOSTTOOLS_DIR/bash as a shell. |
| 51 | export POSIX_SHELL="${base_bindir}/sh" |
| 52 | |
| 53 | LDFLAGS_append_libc-musl = " -largp" |
| 54 | |
| 55 | do_configure_prepend() { |
| 56 | for dir in . lib; do |
| 57 | rm -f ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4 |
| 58 | done |
| 59 | } |
| 60 | |
| 61 | PACKAGES =+ "${PN}-openssl ${PN}-xx" |
| 62 | |
| 63 | FILES_${PN}-dev += "${bindir}/gnutls-cli-debug" |
| 64 | FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*" |
| 65 | FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*" |
| 66 | |
| 67 | BBCLASSEXTEND = "native nativesdk" |