blob: 02f01cc60f86bb50a9b5384b5ec169db2fba00f7 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001# Copyright (C) 2015 Igor Santos <igor.santos@aker.com.br>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Universal Ctags"
5DESCRIPTION = "Universal Ctags is a multilanguage reimplementation of the \
6 Unix ctags utility. Ctags generates an index of source code \
7 definitions which is used by numerous editors and utilities \
8 to instantly locate the definitions."
9
10HOMEPAGE = "https://ctags.io/"
11
Andrew Geissler9aee5002022-03-30 16:27:02 +000012LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +000013LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
14
15inherit autotools-brokensep pkgconfig manpages
16
Andrew Geisslerd5838332022-05-27 11:33:10 -050017SRCREV = "3f9e162a2a2d49920550bddb6de9da46a8340a41"
Andrew Geissler595f6302022-01-24 19:11:47 +000018SRC_URI = "git://github.com/universal-ctags/ctags;branch=master;protocol=https"
19
20S = "${WORKDIR}/git"
21
22PACKAGECONFIG ??= " \
23 readcmd \
24 xml \
25 json \
26 yaml \
27"
28PACKAGECONFIG[readcmd] = "--enable-readcmd,--disable-readcmd"
29PACKAGECONFIG[etags] = "--enable-etags,--disable-etags"
30PACKAGECONFIG[xml] = "--enable-xml,--disable-xml,libxml2"
31PACKAGECONFIG[json] = "--enable-json,--disable-json,jansson"
32PACKAGECONFIG[seccomp] = "--enable-seccomp,--disable-seccomp,libseccomp"
33PACKAGECONFIG[yaml] = "--enable-yaml,--disable-yaml,libyaml"
34PACKAGECONFIG[manpages] = ",,python3-docutils-native"