blob: 8b0218c83e7bcb264fd3770d14dcd671043dfcb2 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Lightweight and flexible command-line JSON processor"
2DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \
3 filter and map and transform structured data with the same \
4 ease that sed, awk, grep and friends let you play with text."
5HOMEPAGE = "https://stedolan.github.io/jq/"
6BUGTRACKER = "https://github.com/stedolan/jq/issues"
7SECTION = "utils"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING;md5=2814b59e00e7918c864fa3b6bbe049b4"
10
11PV = "1.6+git${SRCPV}"
12SRC_URI = "git://github.com/stedolan/jq;protocol=https;branch=master"
13SRCREV = "a9f97e9e61a910a374a5d768244e8ad63f407d3e"
14S = "${WORKDIR}/git"
15
16inherit autotools-brokensep
17
18PACKAGECONFIG ?= "oniguruma"
19
20PACKAGECONFIG[docs] = "--enable-docs,--disable-docs,ruby-native"
21PACKAGECONFIG[maintainer-mode] = "--enable-maintainer-mode,--disable-maintainer-mode,flex-native bison-native"
22PACKAGECONFIG[oniguruma] = "--with-oniguruma,--without-oniguruma,onig"
23
Andrew Geisslerd5838332022-05-27 11:33:10 -050024EXTRA_OECONF += " \
Andrew Geissler595f6302022-01-24 19:11:47 +000025 --disable-valgrind \
26"
27
28BBCLASSEXTEND = "native"