blob: 3ee2b5c239e0268abf933f8e40faa85fc0c78010 [file] [log] [blame]
Andrew Geisslerd5838332022-05-27 11:33:10 -05001SUMMARY = "cpulimit is a tool which limits the CPU usage of a process"
2HOMEPAGE = "http://cpulimit.sourceforge.net"
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86c1c0d961a437e529db93aa3bb32dc4"
5SRCREV ?= "f4d2682804931e7aea02a869137344bb5452a3cd"
6
7SRC_URI = "git://g...@github.com/opsengine/cpulimit.git;protocol=https;branch=master \
8 file://0001-Remove-sys-sysctl.h-and-add-missing-libgen.h-include.patch \
9 "
10
11S = "${WORKDIR}/git"
12
13do_compile() {
14 oe_runmake all
15}
16do_install() {
17 install -d ${D}${sbindir}
18 install -m 0755 ${B}/src/${PN} ${D}${sbindir}/
19}
20
21CFLAGS += "${LDFLAGS}"
22