blob: fc2b0ae75b9f3a99446a3dbec6ba0dae032cbdba [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "httplib2 caching for requests"
2HOMEPAGE = "https://pypi.org/project/CacheControl/"
3LICENSE = "Apache-2.0"
Andrew Geisslerd5838332022-05-27 11:33:10 -05004LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=12;endline=12;md5=942a721dac34d073453642ffe5fcf546"
Andrew Geissler595f6302022-01-24 19:11:47 +00005
6# On PyPi, this is "CacheControl", rather than "cachecontrol", so we need to
7# override PYPI_PACKAGE so fetch succeeds.
8PYPI_PACKAGE = "CacheControl"
9
Andrew Geisslerd5838332022-05-27 11:33:10 -050010SRC_URI[sha256sum] = "a5b9fcc986b184db101aa280b42ecdcdfc524892596f606858e0b7a8b4d9e144"
Andrew Geissler595f6302022-01-24 19:11:47 +000011
12inherit pypi setuptools3
13
14RDEPENDS:${PN} += "\
15 python3-crypt \
16 python3-datetime \
17 python3-email \
18 python3-lockfile \
19 python3-json \
20 python3-logging \
21 python3-msgpack \
22 python3-netclient \
23 python3-pickle \
24 python3-requests \
25 python3-urllib3 \
26 python3-mmap \
27"
28
29BBCLASSEXTEND = "native nativesdk"