blob: 3422dd711c1908530a1480df3a3215e313131b62 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "Google API client core library"
2HOMEPAGE = "https://github.com/googleapis/python-api-core"
3AUTHOR = "Google LLC"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7inherit pypi setuptools3
8
Andrew Geisslerd5838332022-05-27 11:33:10 -05009SRC_URI[sha256sum] = "17957f0704cbe95bd2ce25019efd2046423978594d181d4263e5dcffd2dbbc79"
Andrew Geissler595f6302022-01-24 19:11:47 +000010
11RDEPENDS:${PN} += "\
12 ${PYTHON_PN}-asyncio \
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-logging \
15 ${PYTHON_PN}-math \
16"
17
18RDEPENDS:${PN} += "\
19 ${PYTHON_PN}-googleapis-common-protos \
20 ${PYTHON_PN}-google-auth \
21 ${PYTHON_PN}-grpcio \
22 ${PYTHON_PN}-protobuf \
23 ${PYTHON_PN}-pytz \
24 ${PYTHON_PN}-requests \
25 ${PYTHON_PN}-six \
26"