blob: e747ae33ba2d029921556b1f5801fdef606dbc74 [file] [log] [blame]
Andrew Geisslerd5838332022-05-27 11:33:10 -05001SUMMARY = "A Python implementation of Recursive Length Prefix encoding (RLP)."
2HOMEPAGE = "https://github.com/ethereum/pyrlp"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=00854fa80a84236706b11f47f23e61e7"
6
7SRC_URI[sha256sum] = "63b0465d2948cd9f01de449d7adfb92d207c1aef3982f20310f8009be4a507e8"
8SRC_URI += "file://0001-setup-don-t-use-setuptools-markdown.patch"
9
10inherit pypi setuptools3
11
12DEPENDS += "python3-pip-native"
13
14RDEPENDS:${PN} += "python3-eth-utils"