blob: 660d4f6f0f7adab4a37b6f00d1d6faf6912d74ee [file] [log] [blame]
Andrew Geisslerd5838332022-05-27 11:33:10 -05001SUMMARY = "A Python library for interacting with Ethereum."
2HOMEPAGE = "https://github.com/ethereum/web3.py"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dc2732bdc5e50382737979791cbb3b7"
6
7SRC_URI[sha256sum] = "a78acc0f0150013755398ae185c8c7063d9db0777aa09733de22242a746bd30c"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-aiohttp \
13 python3-distutils \
14 python3-eth-account \
15 python3-idna \
16 python3-lru-dict \
17 python3-requests \
18 python3-setuptools \
19 python3-websockets \
20"