blob: 429905831594a01b1aa032e8ff2956b598e08960 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Provides a wrapper in Python to LDAP"
2DESCRIPTION = "This module provides access to the LDAP \
3(Lightweight Directory Access Protocol) through Python operations \
4instead of C API. The module mainly acts as a wrapper for the \
5OpenLDAP 2.x libraries. Errors will appear as exceptions."
6HOMEPAGE = "http://www.python-ldap.org/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "PSF-2.0"
Andrew Geissler595f6302022-01-24 19:11:47 +00008LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
9
10DEPENDS = "python3 openldap cyrus-sasl"
11
12PYPI_PACKAGE = "python-ldap"
13
14inherit pypi setuptools3
15
16SRC_URI[sha256sum] = "60464c8fc25e71e0fd40449a24eae482dcd0fb7fcf823e7de627a6525b3e0d12"
17
18do_configure:prepend() {
19 sed -i -e 's:^library_dirs =.*::' \
20 -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' \
21 -e 's/= ldap_r/= ldap/g' ${S}/setup.cfg
22}
23
24RDEPENDS:${PN} = " \
25 ${PYTHON_PN}-pprint \
26 ${PYTHON_PN}-threading \
27 ${PYTHON_PN}-pyasn1 \
28 ${PYTHON_PN}-pyasn1-modules \
29"