blob: 45de45564342b33c0181562e7ef9138ddf014bbe [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Web-based MySQL administration interface"
2HOMEPAGE = "http://www.phpmyadmin.net"
3# Main code is GPLv2, vendor/tecnickcom/tcpdf is under LGPLv3, js/jquery is under MIT
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only & LGPL-3.0-only & MIT"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://vendor/tecnickcom/tcpdf/LICENSE.TXT;md5=dd6470bbcd3436ca317f82d34abaf688 \
7 file://js/vendor/jquery/MIT-LICENSE.txt;md5=de877aa6d744cc160ff41c26a8e4811f \
8"
9
10SRC_URI = "https://files.phpmyadmin.net/phpMyAdmin/${PV}/phpMyAdmin-${PV}-all-languages.tar.xz \
11 file://apache.conf \
12"
13
Andrew Geisslerd5838332022-05-27 11:33:10 -050014SRC_URI[sha256sum] = "66da31ca295f06182ac3f2e6e96057dc824c459baedf4b29de6ed0d3be039230"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000015
16UPSTREAM_CHECK_URI = "https://www.phpmyadmin.net/downloads/"
17UPSTREAM_CHECK_REGEX = "phpMyAdmin-(?P<pver>\d+(\.\d+)+)-all-languages.tar.xz"
18
19S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages"
20
21inherit allarch
22
23do_install() {
24 install -d ${D}${datadir}/${BPN}
25 cp -R --no-dereference --preserve=mode,links -v * ${D}${datadir}/${BPN}
26 chown -R root:root ${D}${datadir}/${BPN}
27 # Don't install patches to target
28 rm -rf ${D}${datadir}/${BPN}/patches
29
30 install -d ${D}${sysconfdir}/apache2/conf.d
31 install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf
32
33 # Remove a few scripts that explicitly require bash (!)
34 rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh
35}
36
37FILES:${PN} = "${datadir}/${BPN} \
38 ${sysconfdir}/apache2/conf.d"
39
40RDEPENDS:${PN} += "bash php-cli"