blob: 4f1d1a31b1068b7d3579ebd72751126cb184e9ae [file] [log] [blame]
Andrew Geisslerd5838332022-05-27 11:33:10 -05001DESCRIPTION = "IMA/EVM control utility"
2LICENSE = "GPL-2.0-with-OpenSSL-exception"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5DEPENDS += "openssl attr keyutils"
6
7DEPENDS:class-native += "openssl-native keyutils-native"
8
9SRC_URI = "https://sourceforge.net/projects/linux-ima/files/${BPN}/${BP}.tar.gz"
10SRC_URI[sha256sum] = "fcf85b31d6292051b3679e5f17ffa7f89b6898957aad0f59aa4e9878884b27d1"
11
12inherit pkgconfig autotools features_check
13
14REQUIRED_DISTRO_FEATURES = "ima"
15REQUIRED_DISTRO_FEATURES:class-native = ""
16
17EXTRA_OECONF:append:class-target = " --with-kernel-headers=${STAGING_KERNEL_BUILDDIR}"
18
19# blkid is called by evmctl when creating evm checksums.
20# This is less useful when signing files on the build host,
21# so disable it when compiling on the host.
22RDEPENDS:${PN}:append:class-target = " util-linux-blkid libcrypto attr libattr keyutils"
23
24BBCLASSEXTEND = "native nativesdk"