blob: 8147fe6e86a8c5b3c44a11c04e053cb8e9747089 [file] [log] [blame]
Patrick Williams93c203f2021-10-06 16:15:23 -05001SUMMARY = "fscrypt is a high-level tool for the management of Linux filesystem encryption"
2DESCIPTION = "fscrypt manages metadata, key generation, key wrapping, PAM integration, \
3and provides a uniform interface for creating and modifying encrypted directories. For \
4a small, low-level tool that directly sets policies, see fscryptctl \
5(https://github.com/google/fscryptcl)."
6HOMEPAGE = "https://github.com/google/fscrypt"
7SECTION = "base"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
10
Patrick Williams93c203f2021-10-06 16:15:23 -050011# fscrypt depends on go and libpam
Patrick Williamsde0582f2022-04-08 10:23:27 -050012DEPENDS += "go-native libpam"
Patrick Williams93c203f2021-10-06 16:15:23 -050013
14SRCREV = "92b1e9a8670ccd3916a7d24a06cab1e4c9815bc4"
Patrick Williams53961c22022-01-20 11:06:23 -060015SRC_URI = "git://github.com/google/fscrypt.git;branch=master;protocol=https"
Andrew Geisslerd5838332022-05-27 11:33:10 -050016
Patrick Williams93c203f2021-10-06 16:15:23 -050017GO_IMPORT = "import"
18
Andrew Geisslerd5838332022-05-27 11:33:10 -050019inherit go goarch features_check
Patrick Williams93c203f2021-10-06 16:15:23 -050020
Andrew Geisslerd5838332022-05-27 11:33:10 -050021REQUIRED_DISTRO_FEATURES = "pam"
22
23S = "${WORKDIR}/git"
Patrick Williams93c203f2021-10-06 16:15:23 -050024
25do_compile() {
26 export GOARCH=${TARGET_GOARCH}
27 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
28 export GOPATH="${WORKDIR}/git"
29
30 # Pass the needed cflags/ldflags so that cgo
31 # can find the needed headers files and libraries
32 export CGO_ENABLED="1"
33 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
34 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
35
36 cd ${S}/src/${GO_IMPORT}
37 oe_runmake
38
39 # Golang forces permissions to 0500 on directories and 0400 on files in
40 # the module cache which prevents us from easily cleaning up the build
41 # directory. Let's just fix the permissions here so we don't have to
42 # hack the clean tasks.
43 chmod -R u+w ${S}/pkg/mod
44}
45
46do_install() {
47 install -d ${D}/${bindir}
48 install ${S}/src/${GO_IMPORT}/bin/fscrypt ${D}/${bindir}/fscrypt
49}
Andrew Geisslerd5838332022-05-27 11:33:10 -050050
51BBCLASSEXTEND = "native nativesdk"