blob: d57e147a7e03bed523b90632925634d175d8ab65 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "The basic file, shell and text manipulation utilities"
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "GPL-3.0-or-later"
Andrew Geisslereff27472021-10-29 15:35:00 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
Andrew Geisslerd5838332022-05-27 11:33:10 -05009 file://src/ls.c;beginline=1;endline=15;md5=1fe89f62614b5e1f5475ec04d5899bc1 \
Andrew Geisslereff27472021-10-29 15:35:00 -050010 "
11DEPENDS = "gmp libcap"
12DEPENDS:class-native = ""
13
14inherit autotools gettext texinfo
15
16SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
17 file://remove-usr-local-lib-from-m4.patch \
Andrew Geisslereff27472021-10-29 15:35:00 -050018 file://0001-local.mk-fix-cross-compiling-problem.patch \
Andrew Geisslereff27472021-10-29 15:35:00 -050019 file://run-ptest \
20 "
21
Andrew Geisslerd5838332022-05-27 11:33:10 -050022SRC_URI[sha256sum] = "61a1f410d78ba7e7f37a5a4f50e6d1320aca33375484a3255eddf17a38580423"
Andrew Geisslereff27472021-10-29 15:35:00 -050023
24# http://git.savannah.gnu.org/cgit/coreutils.git/commit/?id=v8.27-101-gf5d7c0842
25# runcon is not really a sandbox command, use `runcon ... setsid ...` to avoid this particular issue.
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000026CVE_CHECK_IGNORE += "CVE-2016-2781"
Andrew Geisslereff27472021-10-29 15:35:00 -050027
28EXTRA_OECONF:class-target = "--enable-install-program=arch,hostname --libexecdir=${libdir}"
29EXTRA_OECONF:class-nativesdk = "--enable-install-program=arch,hostname"
30
31# acl and xattr are not default features
32#
33PACKAGECONFIG:class-target ??= "\
34 ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \
35"
36
37# The lib/oe/path.py requires xattr
38PACKAGECONFIG:class-native ??= "xattr"
39
40# oe-core builds need xattr support
41PACKAGECONFIG:class-nativesdk ??= "xattr"
42
43# with, without, depends, rdepends
44#
45PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
46PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
47PACKAGECONFIG[single-binary] = "--enable-single-binary,--disable-single-binary,,"
48PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
49
50# [ df mktemp nice printenv base64 gets a special treatment and is not included in this
51bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname du \
52 env expand expr factor fmt fold groups head hostid id install \
53 join link logname md5sum mkfifo nl nohup nproc od paste pathchk \
54 pinky pr printf ptx readlink realpath runcon seq sha1sum sha224sum sha256sum \
55 sha384sum sha512sum shred shuf sort split sum tac tail tee test timeout \
56 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
57
58# hostname gets a special treatment and is not included in this
59base_bindir_progs = "cat chgrp chmod chown cp date dd echo false hostname kill ln ls mkdir \
60 mknod mv pwd rm rmdir sleep stty sync touch true uname stat"
61
62sbindir_progs= "chroot"
63
64# Split stdbuf into its own package, so one can include
65# coreutils-stdbuf without getting the rest of coreutils, but make
66# coreutils itself pull in stdbuf, so IMAGE_INSTALL += "coreutils"
67# always provides all coreutils
68PACKAGE_BEFORE_PN:class-target += "${@bb.utils.contains('PACKAGECONFIG', 'single-binary', '', 'coreutils-stdbuf', d)}"
69FILES:coreutils-stdbuf = "${bindir}/stdbuf ${libdir}/coreutils/libstdbuf.so"
70RDEPENDS:coreutils:class-target += "${@bb.utils.contains('PACKAGECONFIG', 'single-binary', '', 'coreutils-stdbuf', d)}"
71
72# However, when the single-binary PACKAGECONFIG is used, stdbuf
73# functionality is built into the single coreutils binary, so there's
74# no point splitting /usr/bin/stdbuf to its own package. Instead, add
75# an RPROVIDE so that rdepending on coreutils-stdbuf will work
76# regardless of whether single-binary is in effect.
77RPROVIDES:coreutils += "${@bb.utils.contains('PACKAGECONFIG', 'single-binary', 'coreutils-stdbuf', '', d)}"
78
79# Let aclocal use the relative path for the m4 file rather than the
80# absolute since coreutils has a lot of m4 files, otherwise there might
81# be an "Argument list too long" error when it is built in a long/deep
82# directory.
83acpaths = "-I ./m4"
84
85# Deal with a separate builddir failure if src doesn't exist when creating version.c/version.h
86do_compile:prepend () {
87 mkdir -p ${B}/src
88}
89
90do_install:class-native() {
91 autotools_do_install
92 # remove groups to fix conflict with shadow-native
93 rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
94 # The return is a must since native doesn't need the
95 # do_install:append() in the below.
96 return
97}
98
99do_install:append() {
100 for i in df mktemp nice printenv base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
101
102 install -d ${D}${base_bindir}
103 [ "${base_bindir}" != "${bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${BPN}; done
104
105 install -d ${D}${sbindir}
106 [ "${sbindir}" != "${bindir}" ] && for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${BPN}; done
107
108 # [ requires special handling because [.coreutils will cause the sed stuff
109 # in update-alternatives to fail, therefore use lbracket - the name used
110 # for the actual source file.
111 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${BPN}
112}
113
114inherit update-alternatives
115
116ALTERNATIVE_PRIORITY = "100"
117# Make hostname's priority higher than busybox but lower than net-tools
118ALTERNATIVE_PRIORITY[hostname] = "90"
119ALTERNATIVE:${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base32 base64 nice printenv mktemp df"
120ALTERNATIVE:${PN}-doc = "base64.1 nice.1 mktemp.1 df.1 groups.1 kill.1 uptime.1 stat.1 hostname.1"
121
122ALTERNATIVE_LINK_NAME[hostname.1] = "${mandir}/man1/hostname.1"
123
124ALTERNATIVE_LINK_NAME[base64] = "${base_bindir}/base64"
125ALTERNATIVE_TARGET[base64] = "${bindir}/base64.${BPN}"
126ALTERNATIVE_LINK_NAME[base64.1] = "${mandir}/man1/base64.1"
127
128ALTERNATIVE_LINK_NAME[mktemp] = "${base_bindir}/mktemp"
129ALTERNATIVE_TARGET[mktemp] = "${bindir}/mktemp.${BPN}"
130ALTERNATIVE_LINK_NAME[mktemp.1] = "${mandir}/man1/mktemp.1"
131
132ALTERNATIVE_LINK_NAME[df] = "${base_bindir}/df"
133ALTERNATIVE_TARGET[df] = "${bindir}/df.${BPN}"
134ALTERNATIVE_LINK_NAME[df.1] = "${mandir}/man1/df.1"
135
136ALTERNATIVE_LINK_NAME[nice] = "${base_bindir}/nice"
137ALTERNATIVE_TARGET[nice] = "${bindir}/nice.${BPN}"
138ALTERNATIVE_LINK_NAME[nice.1] = "${mandir}/man1/nice.1"
139
140ALTERNATIVE_LINK_NAME[printenv] = "${base_bindir}/printenv"
141ALTERNATIVE_TARGET[printenv] = "${bindir}/printenv.${BPN}"
142
143ALTERNATIVE_LINK_NAME[lbracket] = "${bindir}/["
144ALTERNATIVE_TARGET[lbracket] = "${bindir}/lbracket.${BPN}"
145
146ALTERNATIVE_LINK_NAME[groups.1] = "${mandir}/man1/groups.1"
147ALTERNATIVE_LINK_NAME[uptime.1] = "${mandir}/man1/uptime.1"
148ALTERNATIVE_LINK_NAME[kill.1] = "${mandir}/man1/kill.1"
149ALTERNATIVE_LINK_NAME[stat.1] = "${mandir}/man1/stat.1"
150
Andrew Geissler9aee5002022-03-30 16:27:02 +0000151# The statx() requires glibc >= 2.28 and linux kernel >= 4.11, it doesn't work
152# when glibc >= 2.28 ((Ubuntu 20.04 in docker) and kernel < 4.11 (Host OS
153# CentOS 7), we can check kernel version and disable it, but that would cause
154# two different signatures for coreutils-native, so disable it unconditionally
155# for deterministic build.
156EXTRA_OECONF:append:class-native = " ac_cv_func_statx=0"
157
Andrew Geisslereff27472021-10-29 15:35:00 -0500158python __anonymous() {
159 for prog in d.getVar('base_bindir_progs').split():
160 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir'), prog))
161
162 for prog in d.getVar('sbindir_progs').split():
163 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('sbindir'), prog))
164}
165
166BBCLASSEXTEND = "native nativesdk"
167
168inherit ptest
169
170RDEPENDS:${PN}-ptest += "bash findutils gawk liberror-perl make perl perl-modules python3-core sed shadow"
171
172# -dev automatic dependencies fails as we don't want libmodule-build-perl-dev, its too heavy
173# may need tweaking if DEPENDS changes
174RRECOMMENDS:coreutils-dev[nodeprrecs] = "1"
175RRECOMMENDS:coreutils-dev = "acl-dev attr-dev gmp-dev libcap-dev bash-dev findutils-dev gawk-dev shadow-dev"
176
177do_install_ptest () {
178 install -d ${D}${PTEST_PATH}/tests
179 cp -r ${S}/tests/* ${D}${PTEST_PATH}/tests
180 sed -i 's/ginstall/install/g' `grep -R ginstall ${D}${PTEST_PATH}/tests | awk -F: '{print $1}' | uniq`
181 install -d ${D}${PTEST_PATH}/build-aux
182 install ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
183 cp ${B}/Makefile ${D}${PTEST_PATH}/
184 cp ${S}/init.cfg ${D}${PTEST_PATH}/
185 cp -r ${B}/src ${D}${PTEST_PATH}/
186 cp -r ${S}/src/*.c ${D}${PTEST_PATH}/src
187 sed -i '/^VPATH/s/= .*$/= ./g' ${D}${PTEST_PATH}/Makefile
188 sed -i '/^PROGRAMS/s/^/#/g' ${D}${PTEST_PATH}/Makefile
189 sed -i '/^Makefile: /s/^.*$/Makefile:/g' ${D}${PTEST_PATH}/Makefile
190 sed -i '/^abs_srcdir/s/= .*$/= \$\{PWD\}/g' ${D}${PTEST_PATH}/Makefile
191 sed -i '/^abs_top_builddir/s/= .*$/= \$\{PWD\}/g' ${D}${PTEST_PATH}/Makefile
192 sed -i '/^abs_top_srcdir/s/= .*$/= \$\{PWD\}/g' ${D}${PTEST_PATH}/Makefile
193 sed -i '/^built_programs/s/ginstall/install/g' ${D}${PTEST_PATH}/Makefile
194 chmod -R 777 ${D}${PTEST_PATH}
195
196 # Disable subcase stty-pairs.sh, it will cause test framework hang
197 sed -i '/stty-pairs.sh/d' ${D}${PTEST_PATH}/Makefile
198
199 # Disable subcase tail-2/assert.sh as it has issues on 32-bit systems
200 sed -i '/assert.sh/d' ${D}${PTEST_PATH}/Makefile
201
202 # Tweak test d_type-check to use python3 instead of python
203 sed -i "1s@.*@#!/usr/bin/python3@" ${D}${PTEST_PATH}/tests/d_type-check
204 install ${B}/src/getlimits ${D}/${bindir}
205
206 # handle multilib
207 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
208}
209
210FILES:${PN}-ptest += "${bindir}/getlimits"