blob: 69255c5a57f09df837765e71612d7e285faccf9a [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Library providing simplified C and Python API to libsolv"
2HOMEPAGE = "https://github.com/rpm-software-management/libdnf"
3DESCRIPTION = "This library provides a high level package-manager. It's core library of dnf, PackageKit and rpm-ostree. It's replacement for deprecated hawkey library which it contains inside and uses librepo under the hood."
4LICENSE = "LGPL-2.1-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
6
7SRC_URI = "git://github.com/rpm-software-management/libdnf;branch=dnf-4-master;protocol=https \
8 file://0001-FindGtkDoc.cmake-drop-the-requirement-for-GTKDOC_SCA.patch \
9 file://0004-Set-libsolv-variables-with-pkg-config-cmake-s-own-mo.patch \
10 file://0001-Get-parameters-for-both-libsolv-and-libsolvext-libdn.patch \
11 file://enable_test_data_dir_set.patch \
12 file://0001-drop-FindPythonInstDir.cmake.patch \
13 file://0001-libdnf-dnf-context.cpp-do-not-try-to-access-BDB-data.patch \
14 "
15
Andrew Geisslerd5838332022-05-27 11:33:10 -050016SRCREV = "1742be5225b3a4928707696db8c69391def55f5a"
Andrew Geissler9aee5002022-03-30 16:27:02 +000017UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(?!4\.90)\d+(\.\d+)+)"
18
19S = "${WORKDIR}/git"
20
21DEPENDS = "glib-2.0 libsolv libcheck librepo rpm gtk-doc libmodulemd json-c swig-native util-linux"
22
23inherit gtk-doc gobject-introspection cmake pkgconfig setuptools3-base
24
25EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DWITH_MAN=OFF -DPYTHON_DESIRED=3 \
26 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DWITH_GIR=ON', '-DWITH_GIR=OFF', d)} \
27 -DWITH_TESTS=OFF \
28 -DWITH_ZCHUNK=OFF \
29 -DWITH_HTML=OFF \
30 "
31EXTRA_OECMAKE:append:class-native = " -DWITH_GIR=OFF"
32EXTRA_OECMAKE:append:class-nativesdk = " -DWITH_GIR=OFF"
33
34BBCLASSEXTEND = "native nativesdk"
35SKIP_RECIPE[libdnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'Does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"
36