blob: 67e5811f3c280a405d2788b94484ae50f0b5b38d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Error - Error/exception handling in an OO-ish way"
2DESCRIPTION = "The Error package provides two interfaces. Firstly \
3Error provides a procedural interface to exception handling. \
4Secondly Error is a base class for errors/exceptions that can \
5either be thrown, for subsequent catch, or can simply be recorded."
6HOMEPAGE = "https://github.com/shlomif/perl-error.pm"
7SECTION = "libs"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
11
Andrew Geisslerd5838332022-05-27 11:33:10 -050012# remove at next version upgrade or when output changes
13PR = "r1"
14HASHEQUIV_HASH_VERSION .= ".1"
15
Andrew Geissler82c905d2020-04-13 13:39:40 -050016DEPENDS += "perl"
17
Patrick Williams213cb262021-08-07 19:21:33 -050018RDEPENDS:${PN} += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050019 perl-module-carp \
20 perl-module-exporter \
21 perl-module-scalar-util \
22 perl-module-overload \
23 perl-module-strict \
24 perl-module-vars \
25 perl-module-warnings \
26"
27
Patrick Williams213cb262021-08-07 19:21:33 -050028RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050029 perl-module-base \
30 perl-module-file-spec \
31 perl-module-io-handle \
32 perl-module-ipc-open3 \
33 perl-module-lib \
34 perl-module-test-more \
35"
36
37SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
38
39SRC_URI[md5sum] = "6732b1c6207e4a9a3e2987c88368039a"
40SRC_URI[sha256sum] = "1a23f7913032aed6d4b68321373a3899ca66590f4727391a091ec19c95bf7adc"
41
42S = "${WORKDIR}/Error-${PV}"
43
44inherit cpan ptest-perl
45
Patrick Williams213cb262021-08-07 19:21:33 -050046do_install:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050047 # test requires "-T" (taint) command line option
48 rm -rf ${B}/t/pod-coverage.t
49}
50
51BBCLASSEXTEND = "native"