blob: 54070e4b9ca3a7b96fab43966a5da15a7d0149f0 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Modern password hashing for your software and your servers."
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
4HOMEPAGE = "https://pypi.org/project/bcrypt/"
5
6DEPENDS += "${PYTHON_PN}-cffi-native"
7
Andrew Geisslerd5838332022-05-27 11:33:10 -05008SRC_URI[sha256sum] = "433c410c2177057705da2a9f2cd01dd157493b2a7ac14c8593a16b3dab6b6bfb"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009
10inherit pypi python_setuptools_build_meta ptest
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN}-ptest += " \
17 ${PYTHON_PN}-pytest \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25RDEPENDS:${PN}:class-target += "\
26 ${PYTHON_PN}-cffi \
27 ${PYTHON_PN}-ctypes \
28 ${PYTHON_PN}-shell \
29 ${PYTHON_PN}-six \
30"