blob: 86d6793670a6eea9f09bc4502c2679811c0d8a0c [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A library for property-based testing"
2HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
5
6PYPI_PACKAGE = "hypothesis"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12 file://test_binary_search.py \
13 file://test_rle.py \
14 "
15
Andrew Geisslerd5838332022-05-27 11:33:10 -050016SRC_URI[sha256sum] = "f5c24a3d3f8a0d8de2dd33079bf1580a3cfbfe74763187d47570fc9beea84c9b"
Andrew Geissler9aee5002022-03-30 16:27:02 +000017
18RDEPENDS:${PN} += " \
19 python3-attrs \
20 python3-compression \
21 python3-core \
22 python3-json \
23 python3-sortedcontainers \
24 python3-statistics \
25 python3-unittest \
26 "
27
28RDEPENDS:${PN}-ptest += " \
29 ${PYTHON_PN}-pytest \
30 "
31
32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/examples
34 install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/
35 install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/
36}
37
38BBCLASSEXTEND = "native nativesdk"