blob: 51e27b843e844c7eb6715aab90c2c938de4689ab [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Setuptools Rust extension plugin"
2DESCRIPTION = "setuptools-rust is a plugin for setuptools to build Rust \
3Python extensions implemented with PyO3 or rust-cpython.\
4\
5Compile and distribute Python extensions written in Rust as easily as if they were written in C."
6HOMEPAGE = "https://github.com/PyO3/setuptools-rust"
7BUGTRACKER = "https://github.com/PyO3/setuptools-rust/issues"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5"
11
12SRC_URI = "https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz"
Andrew Geisslerd5838332022-05-27 11:33:10 -050013SRC_URI[sha256sum] = "958c5bf4ab6483d59dab888538121871cc5006354a42fb0fbd50acf03caad1de"
Andrew Geissler9aee5002022-03-30 16:27:02 +000014
Andrew Geisslerd5838332022-05-27 11:33:10 -050015inherit cargo pypi python_setuptools_build_meta
Andrew Geissler9aee5002022-03-30 16:27:02 +000016
17DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
18
19RDEPENDS:${PN}:class-native += " \
20 python3-semantic-version-native \
21 python3-setuptools-native \
22 python3-setuptools-scm-native \
23 python3-toml-native \
24 python3-typing-extensions-native \
25 python3-wheel-native \
26"
Andrew Geisslerd5838332022-05-27 11:33:10 -050027
28BBCLASSEXTEND = "native"