blob: 26dbe517671f4b093b88afd2ad567c8d301204bc [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Simple Python module for working with HTML/CSS color definitions."
2HOMEPAGE = "https://pypi.org/project/webcolors/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=25b90379a52351261c51272e7923d240"
5
6SRC_URI[md5sum] = "54d28a7c80b3e4d974ec2fee86768be9"
7SRC_URI[sha256sum] = "76f360636957d1c976db7466bc71dcb713bb95ac8911944dffc55c01cb516de6"
8
9inherit pypi setuptools3 ptest
10
11RDEPENDS:${PN}:class-target = "\
12 ${PYTHON_PN}-stringold \
13"
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28BBCLASSEXTEND = "native nativesdk"