blob: b7332515c85e973adefcf69bed0ad30fd58ca353 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001# SPDX-License-Identifier: MIT
2# Copyright (C) 2021 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "Tool for managing many Git repositories"
5DESCRIPTION = "Repo is a tool built on top of Git. Repo helps manage many Git repositories, does the uploads to revision control systems, and automates parts of the development workflow."
6HOMEPAGE = "https://android.googlesource.com/tools/repo"
7SECTION = "console/utils"
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12SRC_URI = "git://gerrit.googlesource.com/git-repo.git;protocol=https;branch=main \
13 file://0001-python3-shebang.patch \
14 "
Andrew Geisslerd5838332022-05-27 11:33:10 -050015SRCREV = "501733c2abb1180679f25b2f78970d73a2f8d413"
Andrew Geissler9aee5002022-03-30 16:27:02 +000016
17MIRRORS += "git://gerrit.googlesource.com/git-repo.git git://github.com/GerritCodeReview/git-repo.git"
18
19S = "${WORKDIR}/git"
20
21do_configure:prepend() {
22 sed -Ei "s/REPO_REV\s*=\s*('|\")stable('|\")/REPO_REV = '${SRCREV}'/g" ${S}/repo
23}
24
25do_install() {
26 install -D ${WORKDIR}/git/repo ${D}${bindir}/repo
27}
28
29RDEPENDS:${PN} = "python3 git"
30
31BBCLASSEXTEND = "native nativesdk"