blob: a7d0c4be6912b1ab6e7d1e65a01cd17b126a8a3f [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Library to handle input devices in Wayland compositors"
2DESCRIPTION = "libinput is a library to handle input devices in Wayland \
3compositors and to provide a generic X.Org input driver. It provides \
4device detection, device handling, input device event processing and \
5abstraction so minimize the amount of custom input code compositors need to \
6provide the common set of functionality that users expect."
7HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
8SECTION = "libs"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=bab4ac7dc1c10bc0fb037dc76c46ef8a"
12
13DEPENDS = "libevdev udev mtdev libcheck"
14
15SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
16 file://run-ptest \
17 file://determinism.patch \
18 "
Andrew Geisslerd5838332022-05-27 11:33:10 -050019SRC_URI[sha256sum] = "ff33a570b5a936c81e6c08389a8581c2665311d026ce3d225c88d09c49f9b440"
Andrew Geissler595f6302022-01-24 19:11:47 +000020
21UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
22
23inherit meson pkgconfig lib_package ptest
24
25# Patch out build directory, otherwise it leaks into ptest binary
26do_configure:append() {
27 sed -i -e "s,${WORKDIR},,g" config.h
28 if [ -e "litest-config.h" ]; then
29 sed -i -e "s,${WORKDIR},,g" litest-config.h
30 fi
31}
32
33PACKAGECONFIG ??= ""
34PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom"
35PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3"
36
37UDEVDIR = "`pkg-config --variable=udevdir udev`"
38
39EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \
40 -Ddocumentation=false \
41 ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true -Dinstall-tests=true', '-Dtests=false -Dinstall-tests=false', d)} \
42 -Dzshcompletiondir=no"
43
44# package name changed in 1.8.1 upgrade: make sure package upgrades work
45RPROVIDES:${PN} = "libinput"
46RREPLACES:${PN} = "libinput"
47RCONFLICTS:${PN} = "libinput"
48
49FILES:${PN}-ptest += "${libexecdir}/libinput/libinput-test-suite"