blob: 6d5a8626d6c2310d2918d83665c5e37b107e2ce6 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Xlib: C Language X Interface library"
2
3DESCRIPTION = "This package provides a client interface to the X Window \
4System, otherwise known as 'Xlib'. It provides a complete API for the \
5basic functions of the window system."
6
7require xorg-lib-common.inc
8
9FILESEXTRAPATHS =. "${FILE_DIRNAME}/libx11:"
10
11PE = "1"
12
13# temporarily override SRC_URI which is hard-coded in xorg-lib-common.inc
14# since new versions of packages use a new compression format - .tar.gz
15SRC_URI = "${XORG_MIRROR}/individual/lib/${XORG_PN}-${PV}.tar.xz"
16
17SRC_URI += "file://disable_tests.patch \
18 "
Andrew Geisslerd5838332022-05-27 11:33:10 -050019SRC_URI[sha256sum] = "081bf42ebab023aa92cfdb20c7af8c5ae13d13e88a5e22f90f4453ef80bbdde4"
Andrew Geissler595f6302022-01-24 19:11:47 +000020
21PROVIDES = "virtual/libx11"
22
23XORG_PN = "libX11"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024LICENSE = "MIT & MIT & BSD-1-Clause & HPND & HPND-sell-variant"
Andrew Geissler595f6302022-01-24 19:11:47 +000025LIC_FILES_CHKSUM = "file://COPYING;md5=172255dee66bb0151435b2d5d709fcf7"
26
27DEPENDS += "xorgproto \
28 xtrans \
29 libxcb \
30 xorgproto-native \
31 autoconf-archive \
32 "
33
34EXTRA_OECONF += "--with-keysymdefdir=${STAGING_INCDIR}/X11/ --disable-xf86bigfont"
35EXTRA_OEMAKE += 'CWARNFLAGS=""'
36
37PACKAGECONFIG ??= "xcms"
38PACKAGECONFIG[xcms] = "--enable-xcms,--disable-xcms"
39
40PACKAGES =+ "${PN}-xcb"
41
42inherit gettext
43
44FILES:${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${datadir}/X11/Xcms.txt"
45FILES:${PN}-xcb += "${libdir}/libX11-xcb.so.*"
46FILES:${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale"
47
48BBCLASSEXTEND = "native nativesdk"