blob: b512b9932d4a944f539618df5a959a04a439418d [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "XWayland is an X Server that runs under Wayland."
2DESCRIPTION = "XWayland is an X Server running as a Wayland client, \
3and thus is capable of displaying native X11 client applications in a \
4Wayland compositor environment. The goal of XWayland is to facilitate \
5the transition from X Window System to Wayland environments, providing \
6a way to run unported applications in the meantime."
7HOMEPAGE = "https://fedoraproject.org/wiki/Changes/XwaylandStandalone"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880"
11
12SRC_URI = "https://www.x.org/archive/individual/xserver/xwayland-${PV}.tar.xz"
Andrew Geisslerd5838332022-05-27 11:33:10 -050013SRC_URI[sha256sum] = "f5d0e0ba37e19bb87c62f61da5970bd204939f2120620964bed4cc8495baa657"
Andrew Geissler9aee5002022-03-30 16:27:02 +000014
15UPSTREAM_CHECK_REGEX = "xwayland-(?P<pver>\d+(\.(?!90\d)\d+)+)\.tar"
16
17inherit meson features_check pkgconfig
18REQUIRED_DISTRO_FEATURES = "x11 opengl"
19
20DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy libxcvt"
21
22OPENGL_PKGCONFIGS = "glx glamor dri3"
23PACKAGECONFIG ??= "${XORG_CRYPTO} \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${OPENGL_PKGCONFIGS}', '', d)} \
25"
26PACKAGECONFIG[dri3] = "-Ddri3=true,-Ddri3=false"
27PACKAGECONFIG[glx] = "-Dglx=true,-Dglx=false,virtual/libgl virtual/libx11"
28PACKAGECONFIG[glamor] = "-Dglamor=true,-Dglamor=false,libepoxy virtual/libgbm,libegl"
29PACKAGECONFIG[unwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind"
30PACKAGECONFIG[xinerama] = "-Dxinerama=true,-Dxinerama=false"
31
32# Xorg requires a SHA1 implementation, pick one
33XORG_CRYPTO ??= "openssl"
34PACKAGECONFIG[openssl] = "-Dsha1=libcrypto,,openssl"
35PACKAGECONFIG[nettle] = "-Dsha1=libnettle,,nettle"
36PACKAGECONFIG[gcrypt] = "-Dsha1=libgcrypt,,libgcrypt"
37
38do_install:append() {
39 # remove files not needed and clashing with xserver-xorg
40 rm -rf ${D}/${libdir}/xorg/
41}
42
43FILES:${PN} += "${libdir}/xorg/protocol.txt"
44
45RDEPENDS:${PN} += "xkbcomp"