blob: 34bc4bf4f497e681e74ef71b6f083475dd3812df [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Python bindings for GStreamer 1.0"
2DESCRIPTION = "GStreamer Python binding overrides (complementing the bindings \
3provided by python-gi) "
4HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
5SECTION = "multimedia"
6
7LICENSE = "LGPL-2.1-or-later"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
9
10SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
Andrew Geisslerd5838332022-05-27 11:33:10 -050011SRC_URI[sha256sum] = "853ea35a1088c762fb703e5aea9c30031a19222b59786b6599956e154620fa2f"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012
13DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
14RDEPENDS:${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
15
16PNREAL = "gst-python"
17
18S = "${WORKDIR}/${PNREAL}-${PV}"
19
20EXTRA_OEMESON += "\
21 -Dtests=disabled \
22 -Dplugin=enabled \
23 -Dlibpython-dir=${libdir} \
24"
25
26# gobject-introspection is mandatory and cannot be configured
27REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
28GIR_MESON_OPTION = ""
29
30inherit meson pkgconfig setuptools3-base upstream-version-is-even gobject-introspection features_check