blob: 3aa9aa7048886a68c0cb33f1f9ec78faa10f48b5 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "GStreamer 1.0 multimedia framework"
2DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
3It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
4HOMEPAGE = "http://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
6SECTION = "multimedia"
7LICENSE = "LGPL-2.1-or-later"
8
9DEPENDS = "glib-2.0 glib-2.0-native libxml2 bison-native flex-native"
10
11inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection ptest-gnome
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=69333daa044cb77e486cc36129f7a770 \
14 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
15
16S = "${WORKDIR}/gstreamer-${PV}"
17
18SRC_URI = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
19 file://run-ptest \
20 file://0001-tests-respect-the-idententaion-used-in-meson.patch;striplevel=3 \
21 file://0002-tests-add-support-for-install-the-tests.patch;striplevel=3 \
22 file://0003-tests-use-a-dictionaries-for-environment.patch;striplevel=3 \
23 file://0004-tests-add-helper-script-to-run-the-installed_tests.patch;striplevel=3 \
24 file://0005-tests-remove-gstbin-test_watch_for_state_change-test.patch \
25 "
Andrew Geisslerd5838332022-05-27 11:33:10 -050026SRC_URI[sha256sum] = "df24e8792691a02dfe003b3833a51f1dbc6c3331ae625d143b17da939ceb5e0a"
Andrew Geissler9aee5002022-03-30 16:27:02 +000027
28PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
29 check \
30 debug \
31 tools"
32
33PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false"
34PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false"
35PACKAGECONFIG[coretracers] = "-Dcoretracers=enabled,-Dcoretracers=disabled"
36PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled"
37PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled_tests=true,-Dtests=disabled -Dinstalled_tests=false"
38PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
39PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils"
40PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion"
41PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled"
42PACKAGECONFIG[setcap] = "-Dptp-helper-permissions=capabilities,,libcap libcap-native"
43
44# TODO: put this in a gettext.bbclass patch
45def gettext_oemeson(d):
46 if d.getVar('USE_NLS') == 'no':
47 return '-Dnls=disabled'
48 # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
49 if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
50 return '-Dnls=disabled'
51 return '-Dnls=enabled'
52
53EXTRA_OEMESON += " \
54 -Ddoc=disabled \
55 -Dexamples=disabled \
56 -Ddbghelp=disabled \
57 ${@gettext_oemeson(d)} \
58"
59
60GIR_MESON_ENABLE_FLAG = "enabled"
61GIR_MESON_DISABLE_FLAG = "disabled"
62
63PACKAGES += "${PN}-bash-completion"
64
65# Add the core element plugins to the main package
66FILES:${PN} += "${libdir}/gstreamer-1.0/*.so"
67FILES:${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
68FILES:${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
69FILES:${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb"
70
71CVE_PRODUCT = "gstreamer"
72
73PTEST_BUILD_HOST_FILES = ""