blob: 90b5530163b46f0e1aa44badd69248da24dad66f [file] [log] [blame]
Gunnar Mills584fe712020-01-24 13:35:33 -06001# This recipe requires online access to build, as it uses NPM for dependency
2# management and resolution.
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8SRC_URI = "git://github.com/openbmc/webui-vue.git"
Andrew Geisslerd5ba08b2021-12-03 20:51:48 +00009SRCREV = "12dc20c3701fe58b7d827ed44d65ac67cee8a4a6"
Gunnar Mills584fe712020-01-24 13:35:33 -060010S = "${WORKDIR}/git"
11
Patrick Williams12fc9392021-08-06 09:16:53 -050012DEPENDS:prepend = "nodejs-native nlf-native "
Gunnar Mills584fe712020-01-24 13:35:33 -060013
14# allarch is required because the files this recipe produces (html and
15# javascript) are valid for any target, regardless of architecture. The allarch
16# class removes your compiler definitions, as it assumes that anything that
17# requires a compiler is platform specific. Unfortunately, one of the build
18# tools uses libsass for compiling the css templates, and it needs a compiler to
19# build the library that it then uses to compress the scss into normal css.
20# Enabling allarch, then re-adding the compiler flags was the best of the bad
21# options
22
23inherit allarch
24
25export CXX = "${BUILD_CXX}"
26export CC = "${BUILD_CC}"
27export CFLAGS = "${BUILD_CFLAGS}"
28export CPPFLAGS = "${BUILD_CPPFLAGS}"
29export CXXFLAGS = "${BUILD_CXXFLAGS}"
30
Patrick Williams12fc9392021-08-06 09:16:53 -050031FILES:${PN} += "${datadir}/www/*"
Gunnar Mills584fe712020-01-24 13:35:33 -060032
Abhishek Patel0b4f5492021-07-19 08:24:26 -050033EXTRA_OENPM ?= ""
34
Gunnar Mills584fe712020-01-24 13:35:33 -060035do_compile () {
36 cd ${S}
37 rm -rf node_modules
38 npm --loglevel info --proxy=${http_proxy} --https-proxy=${https_proxy} install
Abhishek Patel0b4f5492021-07-19 08:24:26 -050039 npm run build ${EXTRA_OENPM}
Gunnar Mills584fe712020-01-24 13:35:33 -060040}
41
42do_install () {
43 # create directory structure
44 install -d ${D}${datadir}/www
45 cp -r ${S}/dist/** ${D}${datadir}/www
46 find ${D}${datadir}/www -type f -exec chmod a=r,u+w '{}' +
47 find ${D}${datadir}/www -type d -exec chmod a=rx,u+w '{}' +
48}
49
Jason M. Bills28d31532021-04-15 13:52:23 -070050do_find_node_licenses() {
51 cd ${S}
52 nlf -s detail > ${LICENSE_DIRECTORY}/${PN}/node-licenses
53}
54
55addtask find_node_licenses after do_compile before do_build