blob: 9f25c0bf8c40efb561ddc546cd9325a0107faf86 [file] [log] [blame]
Ed Tanous132c0962018-05-31 15:07:49 -07001SUMMARY = "Phosphor OpenBMC KCS to DBUS"
2DESCRIPTION = "Phosphor OpenBMC KCS to DBUS."
3PR = "r1"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=b1beb00e508e89da1ed2a541934f28c0"
7
8inherit autotools pkgconfig
9inherit obmc-phosphor-dbus-service
10
11PV = "1.0+git${SRCPV}"
12
13KCS_DEVICE ?= "ipmi-kcs3"
14
15DBUS_SERVICE_${PN} = "org.openbmc.HostIpmi.service"
16SYSTEMD_SUBSTITUTIONS += "KCS_DEVICE:${KCS_DEVICE}:${DBUS_SERVICE_${PN}}"
17
18PROVIDES += "virtual/obmc-host-ipmi-hw"
19RPROVIDES_${PN} += "virtual-obmc-host-ipmi-hw"
20RRECOMMENDS_${PN} += "phosphor-ipmi-host"
21
22DEPENDS += " \
23 autoconf-archive-native \
24 systemd \
25 "
26RDEPENDS_${PN} += "libsystemd"
27
28S = "${WORKDIR}/git"
29SRC_URI = "git://github.com/openbmc/kcsbridge.git;protocol=https"
30SRCREV = "a1c50751b57a73ee38469c03960831ace72bc860"
31
32# This is how linux-libc-headers says to include custom uapi headers
33CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
34do_configure[depends] += "virtual/kernel:do_shared_workdir"