blob: c641c265e231fb0fd973b5dbc9ba4d1f6b2c7524 [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "A suite for man in the middle attacks"
2HOMEPAGE = "https://github.com/Ettercap/ettercap"
3LICENSE = "GPL-2.0+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6inherit cmake
7
8DEPENDS += "ethtool \
9 geoip \
10 librepo \
11 libnet \
12 libpcap \
13 ncurses \
14 openssl \
15 zlib \
16 bison-native \
17 flex-native \
18 "
19
20RDEPENDS_${PN} += "bash ethtool libgcc"
21
22SRC_URI = "gitsm://github.com/Ettercap/ettercap"
23
24SRCREV = "7281fbddb7da7478beb1d21e3cb105fff3778b31"
25
26S = "${WORKDIR}/git"
27
28EXTRA_OECMAKE = " \
29 -DCMAKE_SKIP_RPATH=TRUE \
30 -DBUNDLED_LIBS=ON \
31 -DENABLE_IPV6=ON \
32 -DENABLE_GTK=OFF \
33"
34
35# Replaces default encoding set (ISO-8859-1) with UTF-8 in ettercap
36# configuration file installed by the package.
37# It ensures that all characters are properly decoded and avoids
38# any fatal errors while running in text mode (-T).
39do_install_append() {
40 sed -i 's@utf8_encoding.*@utf8_encoding = "UTF-8"@g' \
41 ${D}/etc/ettercap/etter.conf
42}