blob: 25500e6501464cfa9e70640500e45216ed1b3607 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Wireless daemon for Linux"
2HOMEPAGE = "https://iwd.wiki.kernel.org/"
3LICENSE = "LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
5
6DEPENDS = "ell"
7
8SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git"
Andrew Geisslerd688a012020-09-18 13:36:00 -05009SRCREV = "aa3dc1b95348dea177e9d8c2c3063b29e20fe2e9"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010S = "${WORKDIR}/git"
11
12inherit autotools manpages pkgconfig python3native systemd
13
14PACKAGECONFIG ??= " \
15 client \
16 monitor \
17 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
18"
19PACKAGECONFIG[client] = "--enable-client,--disable-client,readline"
20PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor"
21PACKAGECONFIG[manpages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native"
22PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
23PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
24PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
25
26EXTRA_OECONF = "--enable-external-ell"
27
28SYSTEMD_SERVICE_${PN} = " \
29 iwd.service \
30 ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)} \
31"
32
33do_configure_prepend() {
34 install -d ${S}/build-aux
35}
36
37do_install_append() {
38 # If client and monitor are disabled, bindir is empty, causing a QA error
39 rmdir --ignore-fail-on-non-empty ${D}/${bindir}
40}
41
42FILES_${PN} += " \
43 ${datadir}/dbus-1 \
Andrew Geisslerd688a012020-09-18 13:36:00 -050044 ${nonarch_libdir}/modules-load.d \
Andrew Geissler82c905d2020-04-13 13:39:40 -050045 ${systemd_unitdir}/network \
46"
47
48RDEPENDS_${PN} = "dbus"
49
50RRECOMMENDS_${PN} = "\
51 kernel-module-pkcs7-message \
52 kernel-module-pkcs8-key-parser \
53 kernel-module-x509-key-parser \
54"