blob: 6ce318d0b59d3301b2da129712e0d0be8ac42efe [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "Eigen is a C++ template library for linear algebra: matrices, vectors, numerical solvers, and related algorithms."
2AUTHOR = "Benoît Jacob and Gaël Guennebaud and others"
3HOMEPAGE = "http://eigen.tuxfamily.org/"
4LICENSE = "MPL-2.0"
5LIC_FILES_CHKSUM = "file://COPYING.MPL2;md5=815ca599c9df247a0c7f619bab123dad"
6
Andrew Geisslerd688a012020-09-18 13:36:00 -05007SRC_URI = "git://gitlab.com/libeigen/eigen.git;protocol=http;nobranch=1"
Brad Bishop19323692019-04-05 15:28:33 -04008
Andrew Geisslerd688a012020-09-18 13:36:00 -05009SRCREV = "21ae2afd4edaa1b69782c67a54182d34efe43f9c"
10
11S = "${WORKDIR}/git"
Brad Bishop19323692019-04-05 15:28:33 -040012
13inherit cmake
14
15FILES_${PN} = "${libdir}"
16FILES_${PN}-dev = "${includedir} ${datadir}/eigen3/cmake ${datadir}/cmake/Modules ${datadir}/pkgconfig"
17
18# ${PN} is empty so we need to tweak -dev and -dbg package dependencies
19RDEPENDS_${PN}-dev = ""
20RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
Brad Bishopb809eb92019-09-18 06:27:43 -040021
22BBCLASSEXTEND = "native nativesdk"