blob: 3a1eaef873e93e8e46c82ac663ce5d644047c98d [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "This is the io_uring library, liburing."
2DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
3instances, and also a simplified interface for applications that don't need \
4(or want) to deal with the full kernel side implementation."
5HOMEPAGE = "https://github.com/axboe/liburing"
6BUGTRACKER = "https://github.com/axboe/liburing/issues"
7SECTION = "libs"
8
9LICENSE = "LGPLv2.1 | MIT"
10LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e6a66ca50904cf9"
11
12SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https"
13SRCREV = "45f0735219a615ae848033c47c7e2d85d101d43e"
14S = "${WORKDIR}/git"
15
16DEPENDS_append_libc-musl = " libucontext"
17XCFLAGS = "-pthread"
18XCFLAGS_append_libc-musl = " -lucontext"
19
20EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
21
22do_install () {
23 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}
24}