blob: dbeb3a60c1f70956a72085fec8f837c53c179249 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A coroutine-based Python networking library"
2DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \
3a high-level synchronous API on top of the libevent event loop."
4HOMEPAGE = "http://www.gevent.org"
5LICENSE = "MIT & Python-2.0 & BSD"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65 \
Brad Bishop19323692019-04-05 15:28:33 -04007 file://NOTICE;md5=18108df3583462cafd457f024b9b09b5 \
8 file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347 \
9 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010DEPENDS += "libevent"
11DEPENDS += "${PYTHON_PN}-greenlet"
12RDEPENDS_${PN} = "${PYTHON_PN}-greenlet \
13 ${PYTHON_PN}-mime \
14 ${PYTHON_PN}-pprint \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015 "
16
17FILESEXTRAPATHS_prepend := "${THISDIR}/python-gevent:"
18
19SRC_URI_append = " \
20 file://libev-conf.patch;patch=1;pnum=1 \
21"
22
Andrew Geisslerd688a012020-09-18 13:36:00 -050023SRC_URI[md5sum] = "27b07fe9fdfff2d75e3d140e890489b1"
24SRC_URI[sha256sum] = "a23c2abf08e851c988723f6a2996d495f513a2c0dc70f9956af03af8debdb5d1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025
26# The python-gevent has no autoreconf ability
27# and the logic for detecting a cross compile is flawed
28# so always force a cross compile
29do_configure_append() {
30 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/libev/configure
31 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/c-ares/configure
32}
33
Andrew Geisslerd688a012020-09-18 13:36:00 -050034inherit pypi setuptools3