blob: 989730186a7c06d3959d72903e07e6959e9edc77 [file] [log] [blame]
Brad Bishop23eaf032019-11-20 05:15:02 -05001SUMMARY = "Simple web browser"
2DESCRIPTION = "Simple open source web browser based on WebKit2/GTK"
3HOMEPAGE = "https://surf.suckless.org/"
4SECTION = "x11/graphics"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=b57e7f7720307a02d5a6598b00fe3afa"
7
8DEPENDS = "webkitgtk gtk+3 glib-2.0"
9
Brad Bishope42b3e32020-01-15 22:08:42 -050010REQUIRED_DISTRO_FEATURES = "x11 opengl"
Brad Bishop23eaf032019-11-20 05:15:02 -050011
12SRC_URI = "git://git.suckless.org/surf;branch=surf-webkit2 \
13 file://0001-config.mk-Fix-compiler-and-linker.patch \
14"
15SRCREV = "b814567e2bf8bda07cea8de1c7a062f4aa437b65"
16
17S = "${WORKDIR}/git"
18
Brad Bishop8410d612019-11-25 09:40:59 -050019inherit pkgconfig features_check
Brad Bishop23eaf032019-11-20 05:15:02 -050020
21TARGET_CC_ARCH += "${LDFLAGS}"
22
23do_install () {
24 install -D -m 0755 ${S}/surf ${D}${bindir}/surf
25}