blob: f8355053d07c4e1a4207d9e0d76ce4d1934e8445 [file] [log] [blame]
Matthew Barth9c525872019-06-12 10:18:39 -05001SUMMARY = "Fan policy configurations for meta-witherspoon machines"
Matthew Barthbc7b43f2019-06-13 12:06:11 -05002PR = "r1"
3LICENSE = "Apache-2.0"
Brad Bishopd77088a2019-09-13 13:06:15 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Matthew Barthbc7b43f2019-06-13 12:06:11 -05005
6inherit allarch
7inherit phosphor-dbus-monitor
8
9FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
10
11SRC_URI += "file://air-cooled.yaml"
Ben_Paifba51212019-08-05 18:34:34 +080012SRC_URI_append_ibm-ac-server = " file://water-cooled.yaml"
Matthew Barthbc7b43f2019-06-13 12:06:11 -050013SRC_URI += "file://fan-errors.yaml"
14
Ben_Paifba51212019-08-05 18:34:34 +080015do_install_append_ibm-ac-server() {
Matthew Barthbc7b43f2019-06-13 12:06:11 -050016 install -D ${WORKDIR}/air-cooled.yaml ${D}${config_dir}/air-cooled.yaml
17 install -D ${WORKDIR}/water-cooled.yaml ${D}${config_dir}/water-cooled.yaml
18 install -D ${WORKDIR}/fan-errors.yaml ${D}${config_dir}/fan-errors.yaml
19}
20
Ben_Paifba51212019-08-05 18:34:34 +080021do_install_append_mihawk() {
22 install -D ${WORKDIR}/air-cooled.yaml ${D}${config_dir}/air-cooled.yaml
23 install -D ${WORKDIR}/fan-errors.yaml ${D}${config_dir}/fan-errors.yaml
24}
25
Matthew Barthbc7b43f2019-06-13 12:06:11 -050026FILES_${PN} += "${config_dir}/air-cooled.yaml"
Ben_Paifba51212019-08-05 18:34:34 +080027FILES_${PN}_append_ibm-ac-server = " ${config_dir}/water-cooled.yaml"
Matthew Barthbc7b43f2019-06-13 12:06:11 -050028FILES_${PN} += "${config_dir}/fan-errors.yaml"