blob: 386a2b93d88a9db0a604b17b6d25dbf87ae2c9d6 [file] [log] [blame]
Ben_Paib24a3e52019-07-15 16:19:02 +08001SUMMARY = "ID Button pressed application"
2PR = "r1"
3LICENSE = "Apache-2.0"
Brad Bishopd77088a2019-09-13 13:06:15 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ben_Paib24a3e52019-07-15 16:19:02 +08005
6inherit obmc-phosphor-systemd
7
8DEPENDS += "virtual/obmc-gpio-monitor"
9RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
10
11S = "${WORKDIR}"
12SRC_URI += "file://toggle_identify_led.sh"
13
14do_install() {
15 install -d ${D}${bindir}
16 install -m 0755 ${WORKDIR}/toggle_identify_led.sh \
17 ${D}${bindir}/toggle_identify_led.sh
18}
19
20SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/id_button"
21
22ID_BUTTON_SERVICE = "id_button"
23
24TMPL = "phosphor-gpio-monitor@.service"
25INSTFMT = "phosphor-gpio-monitor@{0}.service"
26TGT = "multi-user.target"
27FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}"
28
29SYSTEMD_SERVICE_${PN} += "id-button-pressed.service"
30SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}"