blob: 3f688b3600dabd5e0db113c46bd5bbee89aa5161 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "VLAN provides vconfig utility"
2SECTION = "misc"
3LICENSE = "GPLv2"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004LIC_FILES_CHKSUM = "file://vconfig.c;beginline=1;endline=19;md5=094ca47de36c20c598b15b32c270ce0a"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05005
6SRC_URI = "http://${BPN}.sourcearchive.com/downloads/${PV}-3ubuntu9/${BPN}_${PV}.orig.tar.gz \
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007 file://no-HOME-includes.patch \
8 file://0001-Add-printf-format-and-silence-format-security-warnin.patch \
9"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010
11SRC_URI[md5sum] = "5f0c6060b33956fb16e11a15467dd394"
12SRC_URI[sha256sum] = "3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb4868842b4cca"
13
14S = "${WORKDIR}/${BPN}"
15
16EXTRA_OEMAKE = "-e MAKEFLAGS="
17
18# comment out MakeInclude in Makefile which sets build environment
19do_configure_append () {
20 sed -i 's/^ include/#^include/' ${S}/Makefile
21}
22
23# ignore strip to avoid yocto errors in stripping
24do_compile () {
25 oe_runmake PLATFORM=ARM 'STRIP=echo' all
26}
27
28do_install () {
29 install -d ${D}/${base_sbindir}
30 install -m 0755 ${S}/vconfig ${D}/${base_sbindir}/
31}