blob: 2a13e483932f313546f1df7c616ab42917ad0c24 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "AbiWord is free word processing program similar to Microsoft(r) Word"
2HOMEPAGE = "http://www.abiword.org"
3SECTION = "x11/office"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
6DEPENDS = " \
7 perl-native \
8 gtk+ \
9 gtkmathview \
10 wv \
11 libglade \
12 libfribidi \
13 jpeg \
14 libpng \
15 librsvg \
16 libwmf-native \
17 asio \
18 evolution-data-server \
19 libxslt \
20 ${@bb.utils.contains('BBFILE_COLLECTIONS', 'office-layer', 'redland rasqal', '', d)} \
21"
22RDEPENDS_${PN}_append_libc-glibc = " \
23 glibc-gconv-ibm850 glibc-gconv-cp1252 \
24 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1 \
25"
26RCONFLICTS_${PN} = "${PN}-embedded"
27
28SRC_URI = " \
29 http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \
30 file://0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch \
31"
32
33LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a"
34
35SRC_URI[md5sum] = "cda6dd58c747c133b421cc7eb18f5796"
36SRC_URI[sha256sum] = "afbfd458fd02989d8b0c6362ba8a4c14686d89666f54cfdb5501bd2090cf3522"
37
38#want 3.x from 3.x.y for the installation directory
39SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
40
41inherit autotools-brokensep pkgconfig
42
43PACKAGECONFIG ??= " \
44 collab-backend-xmpp collab-backend-tcp \
45 ${@bb.utils.contains('BBFILE_COLLECTIONS', 'office-layer', 'libical', '', d)} \
46"
47PACKAGECONFIG[libical] = "--with-libical,--without-libical,libical raptor2"
48PACKAGECONFIG[spell] = "--enable-spell,--disable-spell,enchant"
49PACKAGECONFIG[collab-backend-xmpp] = "--enable-collab-backend-xmpp,--disable-collab-backend-xmpp,libgsf libxml2 loudmouth"
50PACKAGECONFIG[collab-backend-tcp] = "--enable-collab-backend-tcp,--disable-collab-backend-tcp,libgsf libxml2"
51PACKAGECONFIG[collab-backend-service] = "--enable-collab-backend-service,--disable-collab-backend-service,libgsf libxml2 libsoup-2.4 gnutls"
52PACKAGECONFIG[collab-backend-telepathy] = "--enable-collab-backend-telepathy,--disable-collab-backend-telepathy,libgsf libxml2 telepathy-glib telepathy-mission-control"
53PACKAGECONFIG[collab-backend-sugar] = "--enable-collab-backend-sugar,--disable-collab-backend-sugar,libgsf libxml2 dbus-glib"
54
55EXTRA_OECONF = " --disable-static \
56 --enable-plugins \
57 --enable-clipart \
58 --enable-templates \
59 --without-gnomevfs \
60 --with-gtk2 \
61 --with-libwmf-config=${STAGING_DIR} \
62"
63
64LDFLAGS += "-lgmodule-2.0"
65
66do_compile() {
67 cd goffice-bits2
68 make goffice-paths.h
69 make libgoffice.la
70 cd ${B}
71 oe_runmake
72}
73
74PACKAGES += " ${PN}-clipart ${PN}-strings ${PN}-systemprofiles ${PN}-templates "
75
76FILES_${PN} += " \
77 ${libdir}/lib${PN}-*.so \
78 ${datadir}/mime-info \
79 ${datadir}/icons/* \
80 ${datadir}/${PN}-${SHRT_VER}/glade \
81 ${datadir}/${PN}-${SHRT_VER}/scripts \
82 ${datadir}/${PN}-${SHRT_VER}/system.profile-en \
83 ${datadir}/${PN}-${SHRT_VER}/system.profile-en_GB \
84 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt \
85 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt-en_GB \
86 ${datadir}/${PN}-${SHRT_VER}/templates/Employee-Directory.awt \
87 ${datadir}/${PN}-${SHRT_VER}/templates/Business-Report.awt \
88 ${datadir}/${PN}-${SHRT_VER}/templates/Fax-Coversheet.awt \
89 ${datadir}/${PN}-${SHRT_VER}/templates/Resume.awt \
90 ${datadir}/${PN}-${SHRT_VER}/templates/Two-Columns.awt \
91 ${datadir}/${PN}-${SHRT_VER}/templates/Memo.awt \
92 ${datadir}/${PN}-${SHRT_VER}/templates/Press-Release.awt \
93 ${datadir}/${PN}-${SHRT_VER}/certs \
94 ${datadir}/${PN}-${SHRT_VER}/ui \
95 ${datadir}/${PN}-${SHRT_VER}/xsl* \
96 ${datadir}/${PN}-${SHRT_VER}/mime-info \
97 ${datadir}/${PN}-${SHRT_VER}/Pr*.xml \
98"
99
100# don't steal /usr/lib/libabiword-3.0.so from ${PN}
101# in this case it's needed in ${PN}
102FILES_${PN}-dev = " \
103 ${includedir} \
104 ${libdir}/pkgconfig \
105 ${libdir}/${PN}*.la \
106 ${libdir}/lib${PN}*.la \
107 ${libdir}/${PN}-${SHRT_VER}/plugins/*.la \
108"
109FILES_${PN}-dbg += "${libdir}/${PN}-${SHRT_VER}/plugins/.debug"
110FILES_${PN}-doc += "${datadir}/${PN}-*/readme*"
111
112FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/strings"
113FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/system.profile*"
114FILES_${PN}-clipart += "${datadir}/${PN}-${SHRT_VER}/clipart"
115FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings"
116FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*"
117FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates"
118
119PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*"
120
121python populate_packages_prepend () {
122 abiword_libdir = d.expand('${libdir}/${PN}-${SHRT_VER}/plugins')
123 do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
124
125 metapkg = "abiword-meta"
126 d.setVar('ALLOW_EMPTY_' + metapkg, "1")
127 d.setVar('FILES_' + metapkg, "")
128 blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
129 metapkg_rdepends = []
130 packages = d.getVar('PACKAGES').split()
131 for pkg in packages[1:]:
132 if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
133 print("Modifying %s" % pkg)
134 metapkg_rdepends.append(pkg)
135 d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends))
136 d.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package')
137 packages.append(metapkg)
138 d.setVar('PACKAGES', ' '.join(packages))
139}
140
141FILES_${PN}-plugin-openxml += "${datadir}/${PN}-${SHRT_VER}/omml_xslt"