blob: 6e474835709251ee57815f1fd0f13a79a2760424 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "An IP address pool manager"
2DESCRIPTION = "IpPool is implemented as a separate server daemon \
3to allow any application to use its address pools. This makes it possible \
4to define address pools that are shared by PPP, L2TP, PPTP etc. It may be \
5useful in some VPN server setups. IpPool comes with a command line \
6management application, ippoolconfig to manage and query address pool \
7status. A pppd plugin is supplied which allows pppd to request IP \
8addresses from ippoold. \
9"
10HOMEPAGE = "http://www.openl2tp.org/"
11SECTION = "console/network"
12LICENSE = "GPLv2+"
13
14SRC_URI = "https://sourceforge.net/projects/openl2tp/files/${BPN}/${PV}/${BPN}-${PV}.tar.gz \
15 file://runtest.sh \
16 file://ippool.service \
17 file://ippool_usl_timer.patch \
18 file://ippool_parallel_make_and_pic.patch \
19 file://ippool_init.d.patch \
20 file://always_syslog.patch \
21 file://makefile-add-ldflags.patch \
22 file://0001-usl_timer-Check-for-return-value-of-write-API.patch \
23 file://0001-Respect-flags-from-env.patch \
24 file://0001-read-returns-ssize_t.patch \
25 file://0002-Mark-first-element-of-a-string-as-null.patch \
26 file://0003-cli-Mark-return-of-strtol-as-long-int.patch \
27 "
28SRC_URI_append_libc-musl = "\
29 file://0002-link-with-libtirpc.patch \
30 file://0003-musl-fixes.patch \
31 "
32
33LIC_FILES_CHKSUM = "file://LICENSE;md5=4c59283b82fc2b166455e0fc23c71c6f"
34SRC_URI[md5sum] = "e2401e65db26a3764585b97212888fae"
35SRC_URI[sha256sum] = "d3eab7d6cad5da8ccc9d1e31d5303e27a39622c07bdb8fa3618eea314412075b"
36
37inherit systemd
38
39DEPENDS = "readline ppp ncurses gzip-native"
40DEPENDS_append_libc-musl = " libtirpc"
41RDEPENDS_${PN} = "rpcbind"
42
43EXTRA_OEMAKE = "CC='${CC}' AS='${AS}' LD='${LD}' AR='${AR}' NM='${NM}' STRIP='${STRIP}'"
44EXTRA_OEMAKE += "PPPD_VERSION=${PPPD_VERSION} SYS_LIBDIR=${libdir}"
45# enable self tests
46EXTRA_OEMAKE += "IPPOOL_TEST=y"
47
48CPPFLAGS += "${SELECTED_OPTIMIZATION}"
49CPPFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/tirpc"
50
51SYSTEMD_SERVICE_${PN} = "ippool.service"
52SYSTEMD_AUTO_ENABLE = "disable"
53
54
55do_compile_prepend() {
56 # fix the CFLAGS= and CPPFLAGS= in main Makefile, to have the extra CFLAGS in env
57 sed -i -e "s/^CFLAGS=/CFLAGS+=/" ${S}/Makefile
58 sed -i -e "s/^CPPFLAGS=/CPPFLAGS+=/" ${S}/Makefile
59
60 sed -i -e "s:-I/usr/include/pppd:-I=/usr/include/pppd:" ${S}/pppd/Makefile
61
62}
63
64
65do_install() {
66 oe_runmake DESTDIR=${D} install
67
68 install -D -m 0755 ${S}/debian/init.d ${D}${sysconfdir}/init.d/ippoold
69 install -D -m 0644 ${WORKDIR}/ippool.service ${D}${systemd_system_unitdir}/ippool.service
70 sed -i -e 's:@SBINDIR@:${sbindir}:g' ${D}${systemd_system_unitdir}/ippool.service
71
72 # install self test
73 install -d ${D}/opt/${BPN}
74 install ${S}/test/all.tcl ${S}/test/ippool.test \
75 ${S}/test/test_procs.tcl ${D}/opt/${BPN}
76 install ${WORKDIR}/runtest.sh ${D}/opt/${BPN}
77 # fix the ../ippoolconfig in test_procs.tcl
78 sed -i -e "s:../ippoolconfig:ippoolconfig:" \
79 ${D}/opt/${BPN}/test_procs.tcl
80}
81
82
83PACKAGES =+ "${PN}-test"
84
85FILES_${PN} += "${libdir}/pppd/${PPPD_VERSION}/ippool.so"
86FILES_${PN}-dbg += "${libdir}/pppd/${PPPD_VERSION}/.debug/ippool.so"
87FILES_${PN}-test = "/opt/${BPN}"
88
89# needs tcl to run tests
90RDEPENDS_${PN}-test += "tcl ${BPN}"
91
92PPPD_VERSION="${@get_ppp_version(d)}"
93
94def get_ppp_version(d):
95 import re
96
97 pppd_plugin = d.expand('${STAGING_LIBDIR}/pppd')
98 if not os.path.isdir(pppd_plugin):
99 return None
100
101 bb.debug(1, "pppd plugin dir %s" % pppd_plugin)
102 r = re.compile("\d*\.\d*\.\d*")
103 for f in os.listdir(pppd_plugin):
104 if os.path.isdir(os.path.join(pppd_plugin, f)):
105 ma = r.match(f)
106 if ma:
107 bb.debug(1, "pppd version dir %s" % f)
108 return f
109 else:
110 bb.debug(1, "under pppd plugin dir %s" % f)
111
112 return None
113