blob: cec1d1f77edf3e0f75e34c58f693a63eefaff654 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Administration tool for arp packet filtering"
2SECTION = "net"
3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
5SRCREV = "f4ab8f63f11a72f14687a6646d04ae1bae3fa45f"
6PV = "0.0.4+git${SRCPV}"
7
8SRC_URI = " \
9 git://git.netfilter.org/arptables \
10 file://0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch \
11 file://arptables-init-busybox.patch \
12 file://arptables-arpt-get-target-fix.patch \
13 file://arptables-remove-bashism.patch \
14 file://arptables.service \
15"
16SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5"
17SRC_URI[arptables.sha256sum] = "e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928"
18
19S = "${WORKDIR}/git"
20SYSTEMD_SERVICE_${PN} = "arptables.service"
21
22inherit systemd
23
24EXTRA_OEMAKE = "'BINDIR=${sbindir}' 'MANDIR=${mandir}'"
25
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026do_install() {
27 oe_runmake install DESTDIR=${D}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
29 install -d ${D}${systemd_unitdir}/system
30 install -m 644 ${WORKDIR}/arptables.service ${D}${systemd_unitdir}/system
31 fi
32}
33
34RDEPENDS_${PN} += "perl"
35
36# the install target is not multi-job safe, but it doesn't do much
37# so we just install serially
38#
39PARALLEL_MAKEINST = "-j1"