blob: cc2959e2b5eac020ec769fb68dcb180147c2e084 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# Copyright (C) 2016 Joe MacDonald <joe_macdonald@mentor.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "iSNS daemon and utility programs"
5DESCRIPTION = "This is a partial implementation of RFC4171, the Internet \
6Storage Name Service (iSNS). The distribution includes the iSNS server, \
7supporting persisten storage of registrations, isnsadm, a command line \
8utility for managing nodes, and isnsdd, a corresponding discovery daemon."
9HOMEPAGE = "http://github.com/gonzoleeman/open-isns/"
10LICENSE = "GPLv2+ & LGPLv2+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
12SECTION = "net"
13
14DEPENDS = "openssl systemd"
15
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016SRC_URI = "git://github.com/open-iscsi/open-isns \
17 file://0001-util.h-endian.h-is-available-on-musl-on-linux.patch \
18 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019
20SRCREV ?= "09954404e948e41eb0fce8e28836018b4ce3d20d"
21
22S = "${WORKDIR}/git"
23
24inherit systemd autotools-brokensep distro_features_check
25# depends on systemd
26REQUIRED_DISTRO_FEATURES = "systemd"
27
28EXTRA_OECONF = " --prefix=${prefix} --enable-shared"
29EXTRA_OEMAKE += "SYSTEMDDIR=${D}${systemd_unitdir}/system"
30
31do_install_append () {
32 oe_runmake INCDIR=${D}${includedir}/libisns/ install_hdrs
33 oe_runmake LIBDIR=${D}${libdir} install_lib
34}
35
36FILES_${PN} += "${libdir} ${systemd_unitdir}"