blob: 2129e379cb2e7243e21ba57bb5f27250d6cd01dc [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Mobile IPv6 and NEMO for Linux"
2DESCRIPTION = "UMIP is an open source implementation of Mobile IPv6 and NEMO \
3Basic Support for Linux. It is released under the GPLv2 license. It supports \
4the following IETF RFC: RFC6275 (Mobile IPv6), RFC3963 (NEMO), RFC3776 and \
5RFC4877 (IPsec and IKEv2)."
6HOMEPAGE = "http://umip.org/"
7SECTION = "System Environment/Base"
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=073dc31ccb2ebed70db54f1e8aeb4c33"
10DEPENDS = "rpm indent-native"
11
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012SRC_URI = "git://github.com/jlanza/umip \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013 file://add-dependency-to-support-parallel-compilation.patch \
14 file://mip6d \
15 file://mip6d.service \
16 file://0001-Add-format-string-to-fprintf-call.patch \
17 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018SRCREV = "7d67209cd1bba2dd0e183a0fa07eeef07964dd14"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019
20S = "${WORKDIR}/git"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050021
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022EXTRA_OECONF = "--enable-vt"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050023
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024inherit autotools-brokensep systemd update-rc.d
25
26INITSCRIPT_NAME = "mip6d"
27INITSCRIPT_PARAMS = "start 64 . stop 36 0 1 2 3 4 5 6 ."
28
29SYSTEMD_SERVICE_${PN} = "mip6d.service"
30SYSTEMD_AUTO_ENABLE = "disable"
31
32do_install_append() {
33 install -D -m 0755 ${WORKDIR}/mip6d ${D}${sysconfdir}/init.d/mip6d
34 install -D -m 0644 ${WORKDIR}/mip6d.service ${D}${systemd_system_unitdir}/mip6d.service
35 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \
36 -e 's,@SBINDIR@,${sbindir},g' \
37 ${D}${systemd_system_unitdir}/mip6d.service
38}
39
40RRECOMMENDS_${PN} = "kernel-module-mip6 kernel-module-ipv6"