blob: ffbe73feee1e6513bf6565ddaff954b61945753e [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Cap'n Proto serialization/RPC system"
2DESCRIPTION = "Cap’n Proto is an insanely fast data interchange format and capability-based RPC system. "
3HOMEPAGE = "https://github.com/sandstorm-io/capnproto"
4SECTION = "console/tools"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://../LICENSE;md5=0a5b5b742baf10cc1c158579eba7fb1d"
8
9SRCREV = "c949a18da5f041a36cc218c5c4b79c7705999b4f"
10SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-${PV}"
11
12EXTRA_OECMAKE += "\
13 -DBUILD_TESTING=OFF \
14"
15
16inherit cmake
17
18S = "${WORKDIR}/git/c++"
19
20PACKAGE_BEFORE_PN = "${PN}-compiler"
21RDEPENDS_${PN}-dev += "${PN}-compiler"
22
23FILES_${PN}-dev += "${libdir}/cmake"
24FILES_${PN}-compiler = "${bindir}"
25
26BBCLASSEXTEND = "native nativesdk"