blob: fae30d771db304714f4fdcbfa0fe03b061f972ec [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Minimalistic C client library for Redis"
2HOMEPAGE = "http://github.com/redis/hiredis"
3LICENSE = "BSD-3-Clause"
4SECTION = "libs"
5DEPENDS = "redis"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=d84d659a35c666d23233e54503aaea51"
8SRC_URI = "git://github.com/redis/hiredis;protocol=git;rev=f58dd249d6ed47a7e835463c3b04722972281dbb \
9 file://0001-Makefile-remove-hardcoding-of-CC.patch"
10
11S = "${WORKDIR}/git"
12
13inherit autotools-brokensep pkgconfig
14
15EXTRA_OEMAKE = "PREFIX=${prefix}"
16
17# By default INSTALL variable in Makefile is equal to 'cp -a', which preserves
18# ownership and causes host-user-contamination QA issue.
19# And PREFIX defaults to /usr/local.
20do_install_prepend() {
21 export INSTALL='cp -r'
22}