blob: ff88533ff04671cc91d7103e04b759a231b0e341 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "pam-ssh-agent-auth"
2DESCRIPTION = "A PAM module which permits authentication via ssh-agent."
3HOMEPAGE = "http://sourceforge.net/projects/pamsshagentauth/"
4SECTION = "libs"
5LICENSE = "openssl & BSD"
6LIC_FILES_CHKSUM = "file://LICENSE.OpenSSL;md5=8ab01146141ded59b75f8ba7811ed05a \
7 file://OPENSSH_LICENSE;md5=7ae09218173be1643c998a4b71027f9b \
8"
9
10SRC_URI = "http://sourceforge.net/projects/pamsshagentauth/files/pam_ssh_agent_auth/v${PV}/pam_ssh_agent_auth-${PV}.tar.bz2"
11SRC_URI[md5sum] = "8dbe90ab3625e545036333e6f51ccf1d"
12SRC_URI[sha256sum] = "3c53d358d6eaed1b211239df017c27c6f9970995d14102ae67bae16d4f47a763"
13
14DEPENDS += "libpam openssl"
15
16# This gets us ssh-agent, which we are almost certain to want.
17#
18RDEPENDS_${PN} += "openssh-misc"
19
20# Kind of unfortunate to have underscores in the name.
21#
22S = "${WORKDIR}/pam_ssh_agent_auth-${PV}"
23
24inherit autotools-brokensep
25
26# Avoid autoreconf. Override the --libexec oe_runconf specifies so that
27# the module is put with the other pam modules. Because it cannot, in general,
28# do a runtime test, configure wants to use rpl_malloc() and rpl_realloc()
29# instead of malloc() and realloc(). We set variables to tell it not to because
30# these functions do not exist.
31#
32do_configure () {
33 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
34 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
35 oe_runconf --without-openssl-header-check --libexecdir=${base_libdir}/security \
36 ac_cv_func_malloc_0_nonnull=yes ac_cv_func_realloc_0_nonnull=yes
37}
38
39# Link with CC. Configure cannot figure out the correct AR.
40#
41do_compile () {
42 oe_runmake LD="${CC}" AR="${AR}"
43}
44
45# This stuff is not any place looked at by default.
46#
47FILES_${PN} += "${base_libdir}/security/pam*"
48FILES_${PN}-dbg += "${base_libdir}/security/.debug"