blob: 86e6d30e222f74b9f7bb0b8a7b44c56d525d5388 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "Zlog is a pure C logging library"
2HOMEPAGE = "https://github.com/HardySimpson/zlog"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6PV = "1.2.12+git${SRCPV}"
7
8SRCREV = "13904dab2878aa2654d0c20fb8600a3dc5f2dd68"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009SRC_URI = "git://github.com/HardySimpson/zlog \
10 file://0001-event.c-Cast-pthread_t-to-unsigned-long-instead-of-u.patch \
11 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012
13S = "${WORKDIR}/git"
14
15inherit pkgconfig
16
17EXTRA_OEMAKE = "CC='${CC}' LD='${LD}'"
18
19do_install() {
20 oe_runmake install PREFIX=${D}${exec_prefix} INSTALL=install
21}