blob: 44d92a0988fbe96def0d51368c37f12f2100dd25 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Open Source multimedia player"
2DESCRIPTION = "mpv is a fork of mplayer2 and MPlayer. It shares some features with the former projects while introducing many more."
3SECTION = "multimedia"
4HOMEPAGE = "http://www.mpv.io/"
5DEPENDS = "zlib ffmpeg jpeg virtual/libx11 xsp libxv \
6 libxscrnsaver libv4l libxinerama \
7"
8
9REQUIRED_DISTRO_FEATURES = "x11"
10
11LICENSE = "GPLv2+"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=91f1cb870c1cc2d31351a4d2595441cb"
13
14# While this item does not require it, it depends on ffmpeg which does
15LICENSE_FLAGS = "commercial"
16
17SRC_URI = " \
18 https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz;name=mpv \
19 http://www.freehackers.org/~tnagy/release/waf-1.8.12;name=waf;subdir=${BPN}-${PV} \
20"
21SRC_URI[mpv.md5sum] = "038d0b660de07ff645ad6a741704ecab"
22SRC_URI[mpv.sha256sum] = "daf3ef358d5f260f2269f7caabce27f446c291457ec330077152127133b71b46"
23SRC_URI[waf.md5sum] = "cef4ee82206b1843db082d0b0506bf71"
24SRC_URI[waf.sha256sum] = "01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f22fca60c98b"
25
26inherit waf pkgconfig pythonnative distro_features_check
27
28# Note: both lua and libass are required to get on-screen-display (controls)
29PACKAGECONFIG ??= " \
30 lua \
31 libass \
32 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \
33"
34PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm"
35PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/mesa"
36PACKAGECONFIG[lua] = "--enable-lua,--disable-lua,lua luajit"
37PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass"
38PACKAGECONFIG[libarchive] = "--enable-libarchive,--disable-libarchive,libarchive"
39PACKAGECONFIG[jack] = "--enable-jack, --disable-jack, jack"
40PACKAGECONFIG[vaapi] = "--enable-vaapi, --disable-vaapi,libva"
41PACKAGECONFIG[vdpau] = "--enable-vdpau, --disable-vdpau,libvdpau"
42PACKAGECONFIG[wayland] = "--enable-wayland, --disable-wayland,wayland libxkbcommon"
43
44SIMPLE_TARGET_SYS = "${@'${TARGET_SYS}'.replace('${TARGET_VENDOR}', '')}"
45
46EXTRA_OECONF = " \
47 --prefix=${prefix} \
48 --target=${SIMPLE_TARGET_SYS} \
49 --confdir=${sysconfdir} \
50 --datadir=${datadir} \
51 --disable-manpage-build \
52 --disable-gl \
53 --disable-libsmbclient \
54 --disable-encoding \
55 --disable-libbluray \
56 --disable-dvdread \
57 --disable-dvdnav \
58 --disable-cdda \
59 --disable-uchardet \
60 --disable-rubberband \
61 --disable-lcms2 \
62 --disable-vapoursynth \
63 --disable-vapoursynth-lazy \
64 ${PACKAGECONFIG_CONFARGS} \
65"
66
67do_configure_prepend () {
68 ln -sf waf-1.8.12 ${S}/waf
69 chmod +x ${S}/waf
70}
71
72FILES_${PN} += "${datadir}/icons"