blob: 84e9bca0ee0c2b080ae74ad01e7c6a7afbe9f9c3 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "DJB daemontools"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://cr.yp.to/daemontools.html"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05003DESCRIPTION = "supervise monitors a service. It starts the service and restarts the \
4service if it dies. The companion svc program stops, pauses, or restarts \
5the service on sysadmin request. The svstat program prints a one-line \
6status report. \
7multilog saves error messages to one or more logs. It optionally timestamps \
8each line and, for each log, includes or excludes lines matching specified \
9patterns. It automatically rotates logs to limit the amount of disk space \
10used. If the disk fills up, it pauses and tries again, without losing any \
11data."
12
13SECTION = "System/Servers"
14
15LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/PD;md5=b3597d12946881e13cb3b548d1173851"
16LICENSE = "PD"
17
18SRC_URI = "http://cr.yp.to/daemontools/${BPN}-${PV}.tar.gz \
19 file://0001-error.h-include-errno.h-instead-of-extern-int.diff \
20 file://0002-supervise.c-.-supervise-may-be-a-symlink-if-it-s-da.diff "
21
Patrick Williamsddad1a12017-02-23 20:36:32 -060022SRC_URI_append_class-target = "file://cross-compile.patch \
23 file://0001-daemontools-Fix-QA-Issue.patch "
24
25SRC_URI_append_class-native = "file://0001-daemontools-native-Fix-a-warning.patch "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026
27SRC_URI[md5sum] = "1871af2453d6e464034968a0fbcb2bfc"
28SRC_URI[sha256sum] = "a55535012b2be7a52dcd9eccabb9a198b13be50d0384143bd3b32b8710df4c1f"
29
30S = "${WORKDIR}/admin/${BPN}-${PV}"
31
32DEPENDS += "daemontools-native"
33DEPENDS_class-native = ""
34
35do_compile() {
36 ./package/compile
37}
38
39do_install() {
40 install -d ${D}/${bindir}
41}
42
43do_install_append_class-native() {
44 install -m 755 ${S}/compile/chkshsgr ${D}/${bindir}
45}
46
47do_install_append_class-target() {
48 install -m755 ${S}/command/* ${D}/${bindir}
49}
50
51BBCLASSEXTEND = "native"