blob: 2636287e3abbcd4aec2122382626eb91338d8b19 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001require ${BPN}.inc
2
3DEPENDS = "zlib-native jpeg-native libpng-native libxext-native libxft-native"
4
5inherit native
6
7EXTRA_OECMAKE += " \
8 -DOPTION_BUILD_SHARED_LIBS=OFF \
9 -DOPTION_USE_THREADS=OFF \
10 -DOPTION_USE_XDBE=OFF \
11 -DOPTION_USE_XFT=OFF \
12 -DOPTION_BUILD_EXAMPLES=OFF \
13 -DOPTION_USE_XINERAMA=OFF \
14 -DOPTION_USE_XFIXES=OFF \
15 -DOPTION_USE_XCURSOR=OFF \
16"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
18do_install_append() {
19 # make sure native fltk-config is not used accidentaly
20 rm -f ${D}${bindir}/fltk-config
21}