blob: b505ac18dd4d911dea26c0d5e0ca544b79265784 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "The GNU portability library"
2DESCRIPTION = "A collection of software subroutines which are designed to \
3be usable on many operating systems. The goal of the project \
4is to make it easy for free software authors to make their \
5software run on many operating systems. Since source is designed \
6to be copied from gnulib, it is not a library per-se, as much \
7as a collection of portable idioms to be used in other projects."
8
9HOMEPAGE = "http://www.gnu.org/software/gnulib/"
10SECTION = "devel"
11LICENSE = "LGPLv2+"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5"
14SRCREV = "b23000de1e47c7d580e0e220966dd1ee42a5e5bc"
15
16SRC_URI = "git://git.sv.gnu.org/gnulib;protocol=git \
17"
18
19S = "${WORKDIR}/git"
20
21do_install () {
22 cd ${S}
23 git checkout master
24 git clone ${S} ${D}/${datadir}/gnulib
25}
26
27do_patch[noexec] = "1"
28do_configure[noexec] = "1"
29do_compile[noexec] = "1"
30do_package[noexec] = "1"
31do_packagedata[noexec] = "1"
32do_package_write_ipk[noexec] = "1"
33do_package_write_deb[noexec] = "1"
34do_package_write_rpm[noexec] = "1"
35
36BBCLASSEXTEND = "native"